Регистрация | Последние сообщения | Персональный список | Поиск | Настройка конференции | Личные данные | Правила конференции | Список участников | Top 64 | Статистика раздела | faq | Что нового v.2.3 | Чат
Skunk Forum - Техника, Наука, Общество » АСУТП »
Вопросы по приборам фирмы Логика (страница 49)

Версия для печати (настроить)
Тема закрыта  Тема закрыта (Valera). Страницы: 1 2 3 4 5 6 7 8 9 10 13 16 19 22 25 28 31 34 37 40 43 44 45 46 47 48 49 50

Новая тема | Тема закрыта

Подписаться

Автор Тема:   Вопросы по приборам фирмы Логика
Valera
Moderator

Сообщений: 4551
Откуда: novosibirsk
Регистрация: Май 2004

написано 03 Февраля 2017 15:22ИнфоIP

volgavod
Должно работать.
Скорости сетей приборов/АДС и сетевые номера должны быть согласованы, по описаниям на эти сети у приборов. Конечно, нужно правильно всё подключить физически.
При тестах приборы должны быть подключены, пинг удостоверит соединение компа-ДЛ-АДС но никак не доступ к сетям приборов. Связь, корректность настроек сети с 761 контролируется индикатором, на М4 вроде только факт обмена данными по запросам из программ а не функционирование шины приборов.


Добавление от 03 Февраля 2017 15:25:

asnik
к ОРС HDA серверу логика сторонним ОРС сервером или СКАДой
Должно быть как обычно, разве только версии HDA сверить.

asnik
Junior Member

Сообщений: 2
Регистрация: Январь 2017

написано 03 Февраля 2017 21:07ИнфоIP

Перепробовал все, что у меня было. KEPServer, Indusoft (скада с ОРС HDA клиентом). Говорят Мастер скада умеет, но у меня ее нет. Поделитесь, кому удалось взять HDA данные с ОРС сервера Логика

volgavod
Junior Member

Сообщений: 2
Откуда: Санкт-Петербург
Регистрация: Февраль 2017

написано 07 Февраля 2017 15:52ИнфоIP

Valera
Подключал АДС99 к ком порту для настройки не удается подключиться (нажимал кнопку тест оранжевая лампочка)
Даже ком порт проверил (подключился "Конфигуратором" к СПТ943 все без проблем)
Распайки шнурков использовал в соответствии с инструкциями (коммутировал разъем М4) одним проводом.
Как его еще проверить ума не приложу.

Добавление от 07 Февраля 2017 16:18:

Valera
Проверил настройки com порта
бит/с - 57600
бит данных - 8
четность - нет
стоповые биты - 1
Управление потоком - нет

может здесь чего не так

Добавление от 08 Февраля 2017 11:06:

Попробовал подключить по lan (сетевая карта комп - АДС99) заводской адрес 192.168.0.127 настройки свойств TCP/IPv4 :
ip-автоматически
тестовый режим (желтенький светодиод)

Терминал term99 показал меню прибора примерно сек 5 потом вырубился term99(свернулось окошко) и на этом все даже не запустить моментально сворачивает окошко
Кто нибудь может подробно описать с какими настройками к этому чуду подключиться чтобы хотя бы была возможность его настройки а то совсем беда.

alex2510
Junior Member

Сообщений: 1
Регистрация: Июнь 2016

написано 08 Февраля 2017 12:25ИнфоIP

Да у Логики их адаптеры для их 9-битных протоколов и их шин вообще неадекватные. Если уж захотели дополнительные деньги за адаптеры брать то могли бы их по нормальному делать. Сам уже хрен знает сколько мучаюсь пытаясь настроить одновременный опрос теплосчетчика OPC сервером и прологом через один интерфейс. Думал через АДС99 и Radius можно но оказалось нифига (хотя в документации сказано можно), сейчас пробую одновременно через АДС99+АПС79----1кабель----у счетчика 2 RS485 запараллелены.

При попытке подключиться через Lan к АДС99 ставте IPv4 вручную из диапазона 192.168.0... маску 255.255.255.0 , проверте адресс адаптера пингуется или нет,term99 под администратором можно попробовать запустить.

volgavod
Junior Member

Сообщений: 3
Откуда: Санкт-Петербург
Регистрация: Февраль 2017

написано 09 Февраля 2017 13:24ИнфоIP

Ура я таки его (АДС99) победил
Порядок общения с прибором
Обязательно использовать ноль модемный кабель (без него нечего путем не выходит)
1. Прибор включен (питание и зеленая лампочка "Режим")
2. Жмем кнопку "Тест" (Желтая лампочка "Режим")
3. Соединяем линию М4 (разъем Х5) и ноль модемный кабель воткнутый в com порт по схеме Табл. 7.3 руководства по эксплуатации (внимательно другие похожие разъемы от приборов "Логика" имеют другую нумерацию пинов но сами разъемы вполне годятся)
4. Запускаем Term99 выбирая com порт к которому подключаетесь
5. Жму на клавиатуре "пробел"

Повторное подключение к прибору начинается с п. 1

Настройки для com порта
бит/с - 9600
бит данных - 8
четность - нет
стоповые биты - 1
Управление потоком - нет

Valera
Moderator

Сообщений: 4562
Откуда: novosibirsk
Регистрация: Май 2004

написано 10 Февраля 2017 04:17ИнфоIP

volgavod
961 на 485 подключился?

AlexAES
Junior Member

Сообщений: 1
Регистрация: Февраль 2017

написано 11 Февраля 2017 00:14ИнфоIP

Около этой темы ходили много раз, но все же... Имеется СПТ961.2 (там же 2 интерфейса RS-485). Необходимо опрашивать его через интерфейс RS-485. Допустим через ХТ3. Я так понял, что если применяется магистральный протокол в режиме обмена "ведущий - ведомый ", то ведь необязательно использовать АПС79, т.к. здесь применяются 8-битные данные. Для этих целей я использую Moxa NPort 5230 (Ethernet -> RS-485). Значение параметра 03 в приборе:2162000016 (еще параллельно СПТ опрашивается через модем, но не суть). Ну так вот, программой ПРОЛОГ я не могу добиться ответа от прибора по RS-485. В программе напротив примера с прибором СПТ961 сделал настройку: Связь->Послед.порт: сетевой адрес прибора=0; скорость = 19200; сетевой адрес компа=1 (пробовал и без шлюза). Moxу тоже настраивал: 8 бит данных, NOPARITY, скорость 19600 и т.д. Не работает. Прибор не опрашивается. Ведь не в АПС79 же дело? Кстати ИД прибора в настройках оставил, как в примере. Может в этом дело? Куда еще можно посмотреть?

Valera
Moderator

Сообщений: 4565
Откуда: novosibirsk
Регистрация: Май 2004

написано 11 Февраля 2017 07:47ИнфоIP

AlexAES
Значение параметра 03 в приборе:2162000016
Что бы на 485 была скорость 19600, справа должна быть 5. Или удвоить скорость у МОХ'ы
ИД прибора пролог сравнивает со значением из параметра 008. Они должны совпадать, но на настройки связи это не влияет.

AlexAES
Junior Member

Сообщений: 2
Регистрация: Февраль 2017

написано 11 Февраля 2017 10:40ИнфоIP

Опечатался- 19200 скорость. Из РЭ на СПТ: v1 – скорость обмена на магистрали; v1=1-600 бод, …, v1=9-115200 бод. Т.о. для 19200 v1=6. Вроде все правильно. Вот про ИД поподробней бы. Я его в ПРОЛОГЕ вообще не изменял, взял как было. Про параметр 008 вообще не знал. Т.е. в приборе он скорее всего другой. И еще. В ПРОЛОГЕ пробовал установить связь на основе примера СПТ961. Хотя потом уже в настройках покопался и увидел, что там можно создать узел СПТ961.1(2). Но так не пробовал. В этом может быть проблема?

Valera
Moderator

Сообщений: 4568
Откуда: novosibirsk
Регистрация: Май 2004

написано 11 Февраля 2017 11:21ИнфоIP

AlexAES
Нет, скорость на 485 это крайняя правая цифра в 003. Третья слева скорость на 232, и эти значения не совпадают.

AlexAES
Junior Member

Сообщений: 3
Регистрация: Февраль 2017

написано 11 Февраля 2017 12:01ИнфоIP

Я понимаю, что для 485 это последняя цифра. Нельзя настраивать так, чтобы скорости по 232 и по 485 совпадали что ли? Вот смотрите: формат данных для параметра 003 следующий: p1e1s1l1r1aa1hh1v1.
где s1 (3-я цифра) – задает скорость обмена по RS232C, скорость выбирается из ряда 300, 600, 1200, 2400, 4800, 9600, 19200, 38400, 57600, 115200 бод, при этом s1 = 0 соответствует скорость 300 бод, … s1 = 9 – 115200 бод; У меня s1=6, что соответствует 19200. Правильно?
Теперь v1 (10-я цифра)– скорость обмена на магистрали; v1 =1 – 600, (2)=1200, (3)=2400, (4)=4800, (5)=9600, (6)=19200, (7)=38400, (8)=57600, v1 = 9 – 115200 бод. У меня v1=6, что соответствует тоже 19200. Т.о. обе цифры = 6. Исправьте, если ошибся, пожалуйста.

Valera
Moderator

Сообщений: 4569
Откуда: novosibirsk
Регистрация: Май 2004

написано 11 Февраля 2017 13:24ИнфоIP

AlexAES
Номера задаются от нуля, для значения v1 = 6 скорость будет 38400. Для s1 = 6 скорость 19200.

AlexAES
Junior Member

Сообщений: 4
Регистрация: Февраль 2017

написано 11 Февраля 2017 14:30ИнфоIP

Значит в РЭ опечатка. Хорошо, попробую поставить v1=5 ~ 19200. Спасибо.

volgavod
Junior Member

Сообщений: 4
Откуда: Санкт-Петербург
Регистрация: Февраль 2017

написано 13 Февраля 2017 15:17ИнфоIP

Valera
Сейчас как раз прикидываю какие настройки в вбить
Схема такая "СПТ943" ->RS232(M4)->"АДС99" ->LAN->"D-Link (DI-524)"->LAN->"PC с OPC "Логика"

Настройки "СПТ943"
NT-"3"
ИД-"3221"
КИ-"0"

Настройки "АДС99"
Режим работы - 1 ("Клиент").
Идентификатор адаптера - "Его серийный номер"
Сжатие данных - "0"
Режим дискретного выхода -"0"
Скорость на магистрали М4 - "9600".
Кол. приборов на магистрали М4 - "5".
Скорость на магистрали RS485 - "9600".
Адрес адаптера на RS-485 - "28".
Старший адрес на RS485 - "29".
TCP-порт/магистраль М4 - "8000".
TCP-порт/магистраль RS485 - "8001".
IP-адрес сервера #1 - 192.168.0.101
TCP-порт сервера #1 - 6881
Пароль сервера #1 - [пустое место]
IP-адрес сервера #2 - 192.168.0.102
TCP-порт сервера #2 - 6882
Пароль сервера #2 - [пустое место]
Период отправки Keep-Alive - "300"
IP-адрес адаптера - 192.168.0.127
IP-адрес шлюза - 192.168.0.1
Маска подсети - 255.255.255.0

Настройки "D-Link (DI-524)" - dynamic IP address

Настройки - "PC"
IP - автоматически

Настройки "OPC "Логика"
Сделал ветку на прибор СПТ943
в настройках указал - TCP/IP
IP сервера 192.168.0.101
порт 6881

Пока ничего не выходить (Нужна ли программа "Коммутатор"?)
ping есть только по адресу 192.168.0.127
Остальное по нулям

AlexAES
Junior Member

Сообщений: 5
Регистрация: Февраль 2017

написано 13 Февраля 2017 18:52ИнфоIP

цитата:
Valera писал:
AlexAES
Номера задаются от нуля, для значения v1 = 6 скорость будет 38400. Для s1 = 6 скорость 19200.

Valera, все же для v1=6 ~ 19200. Создал новый узел СПТ961.1(2), поставил нужный ИД, выбрал соединение через шлюз с адресом =1, а скорость АВТО. Соединение с прибором установилось. В момент связи в МОХе посмотрел скорость, она была 19200. Затем поставил принудительно скорость = 19200. Все работает. Спасибо за помощь.

ExplorerOL
Junior Member

Сообщений: 1
Откуда: Россия
Регистрация: Март 2017

написано 21 Марта 2017 11:07ИнфоIP

Добрый день! Тоже промучился с подключением корректора СПГ761.2 к сети Ethernet два дня, поэтому решил поделиться информацией. Большое спасибо всем участникам форума, так как без информации в предыдущих сообщениях я вряд ли бы справился. Опишу, как было у меня.
Несколько раз перечитывал предыдущие сообщения, но все равно оставалось много вопросов. У меня была задача подключить СПГ761.2 в сеть Ethernet для удаленного опроса показаний с помощью конвертера интерфейсов RS485->Ethernet Moxa NPort5130. Сначала общие рекомендации (как я делал сам), когда ничего не получалось.
1. Я использовал программу «Пролог» v 3.6.2
2. Для опроса прибора нужно использовать менеджер удаленного опроса приборов (кнопка с желтым телефоном), просто опросить прибор (кнопка с вилкой) не получается.
3. Тип шины (первый параметр спецификации) установить 2 (ведущий-ведомый), так как, по предыдущим сообщениям, иначе связь настроить не получится.
4. Выставлять обе спецификации коммуникаций (параметры 003 и 004) одинаковыми
5. Выбрать и использовать везде одну скорость передачи, например 9600 бод (чтобы не ошибиться)
6. Правильно распаять разъем для подключения конвертора.
Провод А (Data+) -> на ножку 3 разъема DB9 адаптера Moxa
Провод B (Data-) -> на ножку 4 разъема DB9 адаптера Moxa
7. IP адрес на конверторе Moxa выставил 192.168.1.1 (как выяснилось, это влияет!)
8. Отключить все лишние кабели и адаптеры от ПК и прибора

Рабочие настройки.
У меня заработала следующая конфигурация: СПГ парамтр 003=004=2050000015
Пролог-> Сервис-> Настройки->Связь-> COMXX (выбрать тот, который эмулируется конвертером в режиме RealCOMPort)
Пролог-> Узел СПГ761-> Свойства -> Связь: Тип соединения Послед. Порт, выбрать нужный номер порта, адрес прибора = 0, установить галочку «Работать без шлюза», адрес компьютера 1, скорость 9600 бод.
Также в свойствах СПГ761 не забыть указать верный ИД прибора (взять значение параметра 008, у меня было 17449)
Moxa с помощью (NPortAdministrator) - режим RealComPort, скорость 9600 бод, бит данных 8, стоповый 1, четность – нет. Потом скорость везде я увеличил до максимальной 115000 бод.
Когда связь заработала локально, нужно было включить адаптер с сеть завода. Я изменил ему IP-адрес на 10.112.XXX.XXX – и Пролог стал выдавать ошибку «Невозможно открыть порт XX: недостаточно физических ресурсов». Вернул назад IP-адрес – опять работает. В общем пришлось на Moxa изменять режим работы на TCP-сервер. Также в Прологе изменить тип подключения на TCP/IP, IP адрес = 10.112.XXX.XXX, порт 4001, адрес прибора = 0, установить галочку «Работать без шлюза», адрес компьютера 1. И заработало!
Всем удачи!

Salmen
Junior Member

Сообщений: 1
Откуда: Беларусь
Регистрация: Июнь 2017

написано 09 Июня 2017 15:22ИнфоIP

Добрый день.
цитата:
Valera писал:
misterwolf
1. Запрос параметра 8 (=1091)в канале 0 к прибору с сетевым адресом 1 через прибор с адресом 0.
Запрос: 10 01 01 80 10 1F 1D 10 02 09 30 09 38 0C 10 03 A4 0D
Ответ: 10 01 80 01 10 1F 03 10 02 09 30 09 38 0C 09 31 30 39 31 09 A1 2F E0 0C 10 03 6C 9D
2. Запрос параметра 3 (=1050000034) в канале 0 к прибору с сетевым адресом 0:
Запрос: 10 01 00 00 10 1F 1D 10 02 09 30 09 33 0C 10 03 74 D3
Ответ: 10 01 00 00 10 1F 03 10 02 09 30 09 33 0C 09 31 30 35 30 30 30 30 30 33 34 09 A1 2F E0 09 0C 10 03 19 52

А можно, пожалуйста, привести пример запроса на чтение временного среза архива? Спасибо.

Valera
Moderator

Сообщений: 4610
Откуда: novosibirsk
Регистрация: Май 2004

написано 14 Июня 2017 06:20ИнфоIP

Salmen
пример запроса на чтение временного среза архива
Запрос архива 65530 на СПГ761 №4 через шлюз №0. 1 труба (первая), время запроса 13.06.17 15:57:00.

Запрос заголовка
10 01 04 80 10 1F 19 10 02 09 30 09 36 35 35 33 30 0C 10 03 63 CA

Ответ
10 01 80 04 10 1F 21 10 02 09 30 09 36 35 35 33 30 0C 09 74 A8 09 E7 09 30 09 39 30 0C 09 74 A8
6F 09 E7 09 30 09 38 35 0C 09 90 A1 09 8C 8F A0 09 30 09 37 38 0C 09 92 AD A2 09 27 43 09 30 09
38 32 0C 09 74 6F E2 30 31 09 E7 09 31 09 32 33 34 0C 09 64 50 E2 30 31 09 AA 8F A0 09 31 09 31
39 35 0C 09 92 E2 30 31 09 27 43 09 31 09 32 30 30 0C 09 50 E2 30 31 09 8C 8F A0 09 31 09 32 30
35 0C 09 84 31 E2 30 31 09 20 09 31 09 32 33 38 0C 09 84 32 E2 30 31 09 20 09 31 09 32 34 32 0C
09 4D E2 30 31 09 E2 09 31 09 32 31 30 0C 09 56 E2 30 31 09 92 AC 33 09 31 09 32 31 35 0C 09 56
E0 E2 30 31 09 92 AC 33 09 31 09 32 32 30 0C 09 68 A3 E2 30 31 09 8C 84 A6 2F AC 33 09 31 09 32
32 35 0C 09 8D 91 AE E2 30 31 09 20 09 31 09 32 34 35 0C 10 03 28 78

Запрос данных
10 01 04 80 10 1F 18 10 02 09 30 09 36 35 35 33 30 0C 09 31 33 09 36 09 31 37 09 31 35 09 35 37 09 30 0C 10 03 D0 01

Ответ, получена запись таблицы на 15:00:00
10 01 80 04 10 1F 20 10 02 09 30 09 36 35 35 33 30 0C 09 31 33 09 36 09 31 37 09 31 35 09 35 37
09 30 0C 09 31 33 09 30 36 09 31 37 09 31 35 09 30 30 09 30 30 0C 09 31 33 09 36 09 31 37 09 31
34 09 30 09 30 30 0C 09 31 0C 09 31 0C 09 30 2E 30 39 38 32 35 38 0C 09 32 30 0C 09 30 0C 09 8D
A5 E2 20 A4 A0 AD AD EB E5 3F 0C 09 8D A5 E2 20 A4 A0 AD AD EB E5 3F 0C 09 8D A5 E2 20 A4 A0 AD
AD EB E5 3F 0C 09 30 0C 09 30 0C 09 30 2E 30 30 30 0C 09 30 2E 30 30 30 0C 09 30 2E 30 30 30 0C
09 8D A5 E2 20 A4 A0 AD AD EB E5 3F 0C 09 30 30 30 30 30 30 30 30 0C 10 03 E2 F9

Расход случился нулевой (неудачно время выбрал)

Salmen
Junior Member

Сообщений: 2
Откуда: Беларусь
Регистрация: Июнь 2017

написано 14 Июня 2017 14:46ИнфоIP

Valera, спасибо.
Ещё вопрос. При чтении временного массива (0E) на запрос (безадресный, канал 1, параметр 210 (часовые значения расхода) с 10.4.17 10:30:0 по 10.4.17 12:30:0) :
10 01 10 1F 0E 10 02 09 31 09 32 31 30 0C 09 31 30 09 34 09 31 37 09 31 32 09 33 30 09 30 0C 09 31 30 09 34 09 31 37 09 31 30 09 33 30 09 30 0C 10 03 56 CF
прибор отвечает:
10 01 10 1F 16 10 02 09 31 09 32 31 30 0C 09 31 30 09 34 09 31 37 09 31 32 09 33 30 09 30 0C 09 31 30 09 34 09 31 37 09 31 30 09 33 30 09 30 0C 10 03 6F 78
Это значит за этот период данных в приборе нет?
Спасибо.

Valera
Moderator

Сообщений: 4612
Откуда: novosibirsk
Регистрация: Май 2004

написано 14 Июня 2017 15:43ИнфоIP

Salmen
Да, так.

maximgichko
Junior Member

Сообщений: 1
Откуда: Курск, Россия
Регистрация: Июнь 2017

написано 15 Июня 2017 11:02ИнфоIP

Доброго времени суток!
Прошу помощи!
Имеется корректор СПГ742, программа пролог 3.6.2.983
Требуется поверка корректора.
Опишите пожалуйста процедуру или дайте ссылку на подробную инструкцию для корректного отключения корректора СПГ, снятия данных, параметров (БД, настроек),
чтобы впоследствии ввести в работу поверенный прибор.

Руководство по эксплуатации читал, конфигуратор установлен для копирования настроек.

[Это сообщение изменил maximgichko (изменение 16 Июня 2017 10:25).]

Страницы: 1 2 3 4 5 6 7 8 9 10 13 16 19 22 25 28 31 34 37 40 43 44 45 46 47 48 49 50

Все время MSK

Открыть | Переместить | Удалить

Новая тема | Тема закрыта
Последние сообщения         
Перейти к:

Свяжитесь с нами | skunksworks.net

Copyright © skunksworks.net, 2000-2017

Разработка и техническая поддержка: skunksworks.net


Рейтинг@Mail.ru Яндекс.Метрика