Регистрация | Последние сообщения | Персональный список | Поиск | Настройка конференции | Личные данные | Правила конференции | Список участников | Top 64 | Статистика раздела | faq | Что нового v.2.3 | Чат
Skunk Forum - Техника, Наука, Общество » АСУТП »
Подключение к Сименсу 414 по Ethernet

Версия для печати (настроить)

Новая тема | Написать ответ

Подписаться

Автор Тема:   Подключение к Сименсу 414 по Ethernet
leon78
Junior Member

Сообщений: 23
Откуда: Россия
Регистрация: Май 2004

написано 03 Февраля 2009 11:52ИнфоПравкаОтветитьIP

Есть контроллер CPU414-4H с модулем CP443-1.
Контроллер пустой (новый).
Нет кабеля MPI для программирования.
Можно ли подключиться из STEP7 по Ethernet для программирования контроллера?
Если можно, то как?

paul-th
Junior Member

Сообщений: 16
Откуда: Екатеринбург
Регистрация: Сентябрь 2008

написано 03 Февраля 2009 12:10ИнфоПравкаОтветитьIP

Если все новое, то наверно все сначала надо сконфигурировать и запрограммировать, а тут без кабеля не обойдешся.

Dmitry M. Gaidash
Moderator

Сообщений: 539
Регистрация: Сентябрь 2005

написано 03 Февраля 2009 12:39ИнфоПравкаОтветитьIP

leon78
1. SIMATIC Manager -> Options -> Set PG/PC Interface -> ISO Ind. Ethernet -> OK
2. HW Config -> CP 443-1 -> General -> Interface -> Properties -> Parameters -> Set MAC Address / use ISO protocol -> прописываем MAC-адрес как на наклейке (если нет желания использовать другой, назначенный самостоятельно) -> OK
3. HW Config -> PLC -> Download -> OK -> View -> находим модуль со своим MAC-адресом -> выбираем -> OK

Все должно прогрузиться. Кабель для начальной загрузки был нужен только для очень старых модулей.

leon78
Junior Member

Сообщений: 24
Откуда: Россия
Регистрация: Май 2004

написано 03 Февраля 2009 16:01ИнфоПравкаОтветитьIP

Спасибо за ответ. Но такая проблема.
При загрузке мой МАС-адрес виден, но при попытке загрузить
3. HW Config -> PLC -> Download -> OK -> View -> находим модуль со своим MAC-адресом -> выбираем -> OK
выдает сообщение типа "соединение не может быть установлено"

Dmitry M. Gaidash
Moderator

Сообщений: 540
Регистрация: Сентябрь 2005

написано 03 Февраля 2009 16:46ИнфоПравкаОтветитьIP

leon78
В списке после нажатия View адрес виден? Как насчет конфигурации железа - карта и процессор в правильных слотах? Корзина правильно выбрана и "набита"?

leon78
Junior Member

Сообщений: 25
Откуда: Россия
Регистрация: Май 2004

написано 03 Февраля 2009 16:57ИнфоПравкаОтветитьIP

цитата:
Dmitry M. Gaidash писал:
leon78
В списке после нажатия View адрес виден? Как насчет конфигурации железа - карта и процессор в правильных слотах? Корзина правильно выбрана и "набита"?

Да, МАС-адрес виден. Даже удалось ему IP-адрес задать. Но при загрузке пишет, что не может установить соединение с контроллером.
Еще странность -там есть в одном окошке кнопка "flash". Я как понял, при нажатии ее модуль должен мигать светодиодами. Но он не мигает, хотя по МАС-адресу виден.
Соединен контроллер к компьютеру кроссовером, напрямую, без свичей.

Dmitry M. Gaidash
Moderator

Сообщений: 541
Регистрация: Сентябрь 2005

написано 03 Февраля 2009 17:06ИнфоПравкаОтветитьIP

leon78
Да, МАС-адрес виден. Даже удалось ему IP-адрес задать
Не совсем понимаю, что это означает. Как удалось ему IP-адрес задать и зачем? Задать в HW Config - так это только на компе изменение отразилось. Если прогрузить ни разу не удалось, то значит и задать не удалось. Далее, IP-адрес нужен только для работы через TCP/IP, для Industrial Ethernet нужен только MAC - сразу вопрос, а выполнен ли 1-й пункт моей "инструкции"?

Но при загрузке пишет, что не может установить соединение с контроллером.
Такое может быть из-за того, что CP-шка или CPU не в том слоте корзины сконфигурированы, в котором они реально установлены.

leon78
Junior Member

Сообщений: 26
Откуда: Россия
Регистрация: Май 2004

написано 04 Февраля 2009 10:38ИнфоПравкаОтветитьIP

Скриншоты здесь:
ссылка

kuzulis
Junior Member

Сообщений: 1
Откуда: Брянск
Регистрация: Февраль 2009

написано 04 Февраля 2009 11:21ИнфоПравкаОтветитьIP

А там по моему слот где втыкнут модуль 4-й по щету.. т.е если нумерация с нуля идет - то должен быть он №3

а в конфиге он под №2 почему то (или я не прав) ?

ведь БП занимает 2 слота

Добавление от 04 Февраля 2009 11:32:

или это не БП - а процессорный модуль на фото?

leon78
Junior Member

Сообщений: 27
Откуда: Россия
Регистрация: Май 2004

написано 04 Февраля 2009 11:50ИнфоПравкаОтветитьIP

Нумерация с 1.
1 - блок питания
2,3 - процессор
4 - модуль Ethernet
5 - модуль Profibus

Dmitry M. Gaidash
Moderator

Сообщений: 542
Регистрация: Сентябрь 2005

написано 04 Февраля 2009 12:46ИнфоПравкаОтветитьIP

leon78
Попробуй прогрузить его по TCP/IP в таком случае - в "Set PG/PC Interface" выбери соответствующий интерфейс и вперед.

leon78
Junior Member

Сообщений: 28
Откуда: Россия
Регистрация: Май 2004

написано 12 Февраля 2009 17:39ИнфоПравкаОтветитьIP

Проблема была в том, что у меня H система. Работал я с 0-м Rack-ом. А переключатель внизу модуля ЦПУ стоял в "1".

Dmitry M. Gaidash
Moderator

Сообщений: 563
Регистрация: Сентябрь 2005

написано 12 Февраля 2009 18:57ИнфоПравкаОтветитьIP

leon78
Бывает

Ваш ответ:

Коды форума
Смайлики


Ник:    Пароль       
Отключить смайлики

Все время MSK

Склеить | Разбить | Закрыть | Переместить | Удалить

Новая тема | Написать ответ
Последние сообщения         
Перейти к:

Свяжитесь с нами | skunksworks.net

Copyright © skunksworks.net, 2000-2018

Разработка и техническая поддержка: skunksworks.net


Рейтинг@Mail.ru Яндекс.Метрика