Регистрация | Последние сообщения | Персональный список | Поиск | Настройка конференции | Личные данные | Правила конференции | Список участников | Top 64 | Статистика раздела | faq | Что нового v.2.3 | Чат
Skunk Forum - Техника, Наука, Общество » Форум разработчиков РЭА »
Генератор на Altera

Версия для печати (настроить)

Новая тема | Написать ответ

Подписаться

Автор Тема:   Генератор на Altera
Весельчак У
Moderator

Сообщений: 14859
Откуда: Санктъ-Питербурхъ
Регистрация: Декабрь 2000

написано 26 Января 2001 01:08ИнфоПравкаОтветитьIP

Вопрос к ПЛИСоделу: как во Flex 10K10 сделать кварцевый генератор, и почему есть проблемы конфигурирования её же при внешнем тактировании?

russian skunk
Administrator

Сообщений: 1609
Откуда: город-герой Ленинград
Регистрация: Ноябрь 2000

написано 26 Января 2001 14:14ИнфоПравкаОтветитьIP

Сделать кварцевый генератор на FLEX мне в свое время не удалось. Делал несколько лет на EPLD, недавно обнаружил забавный глюк. При изменении версии проекта тактовый сигнал не приходил на одну макроячейку. Пришлось поставить внешний генератор, что и всем остальным теперь советую это делать.

Про проблемы конфигурирования при внешнем тактировании, подробнее. Их не должно быть.

Весельчак У
Moderator

Сообщений: 14859
Откуда: Санктъ-Питербурхъ
Регистрация: Декабрь 2000

написано 31 Января 2001 03:12ИнфоПравкаОтветитьIP

Проблемы такие: при подключенном работающем генераторе MAX+Plus 2 через BitBlaster отказывается конфигурировать. Пробовали использовать разные выводы для подключения генератора - всё бесполезно.

russian skunk
Administrator

Сообщений: 1609
Откуда: город-герой Ленинград
Регистрация: Ноябрь 2000

написано 31 Января 2001 13:07ИнфоПравкаОтветитьIP

BitBlaster - это который в COM втыкается? Подробнее, что за режим конфигурации, что за внешний генератор? Как мне отвечать, если ты мне исходной информации не даешь? По опыту могу сказать, что возможность программировать в системе - это немножко вранье. В некоторых проектах, при наличии внешних сигналов, конфигурация не проходит.

Весельчак У
Moderator

Сообщений: 14859
Откуда: Санктъ-Питербурхъ
Регистрация: Декабрь 2000

написано 01 Февраля 2001 02:56ИнфоПравкаОтветитьIP

BitBlaster - подключается одним концом к LPT, а другим, к конфигурационным выводам Alter'ы. Внешний генератор самый обычный, в корпусе, напоминающем "посол", хотя и в других, бОльших, разницы нет. Режим конфигурации? Не понял вопроса. Разве есть разные режимы? Выбираешь BitBlaster, жмёшь кнопку конфигурирования и... облом. А потом придётся грузиться из конфигурационного ПЗУ, а генератор работает... Можно, конечно, выключать ему питание, или ставить внешний корпус с вентилем, но сам принцип, что такие вещи имеются, очень огорчает.

russian skunk
Administrator

Сообщений: 1609
Откуда: город-герой Ленинград
Регистрация: Ноябрь 2000

написано 01 Февраля 2001 21:45ИнфоПравкаОтветитьIP

Ну, во-первых, то что втыкается в LPT называется ByteBlaster.
Во-вторых, я только сейчас кажется понял, что генератор сделан не на внутреннем инверторе кристалла (хотя в названии темы подразумевалось это), а действительно полностью внешний. Надеюсь его выход завели на глобальный тактовый вход?
Разве есть разные режимы?
Ну, загружать можно через JTAG, или через конфигурационные входы. Да и ничего не сказано сколько кристаллов в цепочке (подозреваю, что один).
Все-таки, что-то здесь не то. Наличие тактовой частоты на GCLK не должно мешать режиму загрузки. Конкретнее надо формулировать проблемы.
PS ByteBlaster самодельный?

Весельчак У
Moderator

Сообщений: 14859
Откуда: Санктъ-Питербурхъ
Регистрация: Декабрь 2000

написано 02 Февраля 2001 15:41ИнфоПравкаОтветитьIP

1. Да, сейчас проверил, действительно ByteBlaster.
2. Вопрос был и про генератор на внутреннем инверторе (не заработал), и про полностью внешний.
Выход внешнего генератора заводился и на глобальный тактовый вход, и на другие входы - без разницы.
3. Повторяю: через конфигурационные входы, кристалловв цепочке 2 (два)
4. ByteBlaster самодельный.

russian skunk
Administrator

Сообщений: 1609
Откуда: город-герой Ленинград
Регистрация: Ноябрь 2000

написано 02 Февраля 2001 18:25ИнфоПравкаОтветитьIP

Похоже в конфе этот вопрос не решить.
На всякий случай уточняю.
1. CONF_DONE, nSTATUS, DCLK, DATA0, nCONFIG соединены параллельно и притянуты к питанию через 1кОМ. MSEL0, MSEL1 на земле. У первого кристалла nCE на земле, его выход nCEO соединен со входом второго nCE.
2. Байт-бластер сделан по схеме MV. Стоит микросхема 74HCT244 вплотную у 10pin разъема, сам кабель не длиннее 50 см.
Если все так, попробуйте с конфигурационного ПЗУ загрузить, может все будет нормально.

Весельчак У
Moderator

Сообщений: 14859
Откуда: Санктъ-Питербурхъ
Регистрация: Декабрь 2000

написано 07 Февраля 2001 13:39ИнфоПравкаОтветитьIP

Почти всё так, только АП5 подключена через кабель ~20 см.Но ведь без генератора конфигурируется нормально!

Где сейчас можно купить конфигурационное ПЗУ? А то что-то не найти. Все завтраками кормят.

russian skunk
Administrator

Сообщений: 1609
Откуда: город-герой Ленинград
Регистрация: Ноябрь 2000

написано 07 Февраля 2001 23:58ИнфоПравкаОтветитьIP

Весельчак У, на всякий случай обзвонил всех спецов. Не было у них таких проблем! Что-то в вашей консерватории не то.

А что, в ЭФО нет? Я бы, кстати, посоветовал бы взять конф. ПЗУ многократньо перешиваемое по JTAG.

Весельчак У
Moderator

Сообщений: 14859
Откуда: Санктъ-Питербурхъ
Регистрация: Декабрь 2000

написано 08 Февраля 2001 02:25ИнфоПравкаОтветитьIP

Вот и сами не понимаем. До какого-то момента было всё нормально, а после очередной модификации - перестало работать. Может кристаллы накрылись? Но что-то уж больно странно.

В ЭФО нет, нашли в Гамме (Выб.).

russian skunk
Administrator

Сообщений: 1609
Откуда: город-герой Ленинград
Регистрация: Ноябрь 2000

написано 08 Февраля 2001 13:24ИнфоПравкаОтветитьIP

Может кристаллы накрылись?

Вполне вероятно. У меня несколько мистических случаев тоже было. После замены кристаллов все нормально работало.

NiM
unregistered
написано 07 Марта 2001 12:55  ПравкаОтветитьIP

Как интересно ! У меня такая хрень тоже была , с FLEX8282.
И с похожим сценарием при реконфигурировании EPM7128S прямо в
схеме на ходу.
А дело было в том , что частота была не слабая , 50 MHz.
А разводка хреновая - слепыш. А провода - длинные. А при отражениях бывают выбросы выше питания Vcc , апропо !
А все Alter-овские камушки того жуть как не любят. Пришлось
согласовывать линию вблизи камня - проблема ушла в зад !
А может , Весельчак прав и генератор глючит ? Они
это любят , особо при "грязном" питании.

Весельчак У
Moderator

Сообщений: 154
Откуда: Санктъ-Питербурхъ
Регистрация: Декабрь 2000

написано 08 Марта 2001 02:56ИнфоПравкаОтветитьIP

NiM
Нет, частота небольшая - 4,092 МГц, питание было разное - ничего не помогло. А самре главное - поначалу работало, а с некоторого момента перестало.

Ваш ответ:

Коды форума
Смайлики


Ник:    Пароль       
Отключить смайлики

Все время MSK

Склеить | Разбить | Закрыть | Переместить | Удалить

Новая тема | Написать ответ
Последние сообщения         
Перейти к:

Свяжитесь с нами | skunksworks.net

Copyright © skunksworks.net, 2000-2018

Разработка и техническая поддержка: skunksworks.net


Рейтинг@Mail.ru Яндекс.Метрика